Cisco 2911 #ROUTER Config. for IP Phone


Here I am gonna explain router config. for cisco router 2911, It 'll help you to configure your router for the Cisco IP phone.  But this post doesn't contain all details for configuring a router for IP phone, only you get the scenario for it.





The config. the part is given below:
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------


User Access Verification

Username: deba
Password:
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to log in to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------

debaINDIA#run config
            ^
% Invalid input detected at '^' marker.

debaINDIA#sh config
Using 9563 out of 262136 bytes
!
! Last configuration change at 19:27:09 UTC Wed Mar 19 2014
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname debaINDIA
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 0
card type e1 0 1
logging buffered 51200 warnings
enable secret 4 fufKw7qsyGE/mWoH1y7TCiBGVH2jeU/aEJBFXMzMV7A
!
no aaa new-model
network-clock-participate wic 0
network-clock-participate wic 1
!
ip cef
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.248
 default-router 10.10.10.1
 lease 0 2
!
!
!
no ip domain lookup
ip domain name yourdomain.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-4ess
!
!
crypto pki trustpoint TP-self-signed-3323577409
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3323577409
 revocation-check none
 rsakeypair TP-self-signed-3323577409
!
!
crypto pki certificate chain TP-self-signed-3323577409
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  bind control source-interface GigabitEthernet0/2
  bind media source-interface GigabitEthernet0/2
  min-se 3600 session-expires 3600
!
voice class h323 60
  h225 timeout tcp establish 2
!
voice class h323 600
  h225 timeout tcp establish 3
!
!
!
!
voice translation-rule 1
 rule 1 /^3336/ /6/
!
voice translation-rule 10
 rule 1 /^333\(6...$\)/ /\1/
!
voice translation-rule 11
 rule 1 /^333\(6...$\)/ /\1/
!
!
voice translation-profile incmng
 translate called 10
!
voice translation-profile incoming
 translate calling 1
 translate called 1
!
!
!
license udi pid CISCO2911/K9 sn FGL180210UF
hw-module pvdm 0/0
!
!
!
username deba privilege 15 secret 4 TtHxWFRFnqbYEU8COFFahqGKpU4tjVeOML1IbAubnPI
!
redundancy
!
!
controller E1 0/0/0
 pri-group timeslots 1-31 service mgcp
 description Reliance PRI
!
controller E1 0/0/1
 pri-group timeslots 1-31 service mgcp
 description BSNL PRI
!
controller E1 0/1/0
 pri-group timeslots 1-31 service mgcp
 description Reliance PRI
!
controller E1 0/1/1
!
!
!
!
!
interface Loopback0
 ip address 172.27.0.103 255.255.255.0
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 10.10.10.1 255.255.255.248
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description voiceSERVER Vlan
 ip address 172.27.5.106 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 172.27.7.250 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip h323-id deba
 h323-gateway voip bind srcaddr 172.27.7.250
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 172.27.5.1
ip route 172.27.0.0 255.255.255.0 172.27.5.1
ip route 172.27.7.0 255.255.255.0 172.27.7.1
!
!
!
access-list 24 permit 172.0.0.0 0.255.255.255
!
control-plane
!
!
voice-port 0/0/0:15
 cptone IN
!
voice-port 0/1/0:15
 cptone IN
!
voice-port 0/0/1:15
 cptone IN
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
 !
 !
 !
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 172.27.5.60
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 172.27.5.58
ccm-manager config
!
mgcp
mgcp call-agent 172.27.5.58 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/2
mgcp bind media source-interface GigabitEthernet0/2
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/2
sccp ccm 172.27.5.60 identifier 2 version 7.0
sccp ccm 172.27.5.58 identifier 1 version 7.0
sccp
!
sccp ccm group 1
 bind interface GigabitEthernet0/2
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register TC_CCM_01
 associate profile 20 register CBC_01
 associate profile 3 register MTP_01
!
dspfarm profile 1 transcode
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum sessions 13
 associate application SCCP
!
dspfarm profile 20 conference
 description dspfram_profile
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 12
 associate application SCCP
!
dspfarm profile 3 mtp
 description software MTP
 codec pass-through
 codec g711ulaw
 maximum sessions software 500
 associate application SCCP
!
dial-peer voice 90 pots
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 91 pots
 description Reliance PRI
 destination-pattern 0T
 port 0/0/0:15
!
dial-peer voice 93 pots
 description BSNL PRI
 destination-pattern 2T
 port 0/0/1:15
!
dial-peer voice 6000 voip
 translation-profile outgoing incoming
 destination-pattern 3336...
 session protocol sipv2
 session target ipv4:172.27.5.58
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 6001 voip
 translation-profile outgoing incoming
 destination-pattern 3336...
 session protocol sipv2
 session target ipv4:172.27.5.60
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 6002 voip
 session protocol sipv2
 session target ipv4:172.27.5.58
 incoming called-number .%
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 6003 voip
 session protocol sipv2
 session target ipv4:172.27.5.60
 incoming called-number .%
 voice-class sip dtmf-relay force rtp-nte
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 94 pots
 incoming called-number .
 direct-inward-dial
 port 0/1/0:15
!
dial-peer voice 95 pots
 description Reliance PRI
 destination-pattern 0T
 port 0/1/0:15
!
dial-peer voice 96 pots
 description BSNL PRI
 incoming called-number .
 direct-inward-dial
 port 0/1/0:15
!
!
!
!
gatekeeper
 shutdown
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for  one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE  PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 24 in
 privilege level 15
 password Cisco2
 login local
 transport input telnet
 transport output telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end 

Post a Comment

Previous Post Next Post